Yii2 安装PHPOffice/PHPExcel报错的解决办法

./composer.phar require "phpoffice/phpexcel": "*"

安装时报如下错误:

Could not find package * at any version for your minimum-stability (dev). Check the package spelling or your minimum-stability

解决办法:

to test installation with composer:

add this to your composer.json config file:

{

"repositories": [

{

"type": "vcs",

"url": "https://github.com/csanquer/PHPExcel.git"

}

],

"minimum-stability": "dev",

"require": {

"phpoffice/phpexcel": "*"

}

}

then run

php composer.phar update

A class mapping is generated in vendor/composer/autoload_classmap.php and you need only to include the autoloader vendor/autoload.php

发表评论

电子邮件地址不会被公开。 必填项已用*标注